RTflow Help
   Definitions
   Tutorials
      Tutorial 1: A Simple Counter
         The Schematic Editor (Tutorial)
         The Simulator (Tutorial)
         The Code Generator (Tutorial)
      Tutorial 2: A PID Controller
         Open and Examine the Model
         Set Up the Simulator View
         Tune the Controller
      Tutorial 3: A Java Game
         Set up the Java environment
         Open and run the game
         Improve the AI
   The Main Window
      Main Window - General
      The File Menu
         New Schematic
         Open...
         Open Recent
         Save
         Save As...
         Save Project As...
         Save All
         Close
         Close All
         Export CSV...
         Print Setup...
         Print...
         Exit
      The Edit Menu
         Undo
         Redo
         Cut
         Copy
         Paste
         Select All
         Delete
         Properties...
      The Project Menu
         Add Files...
         Remove File...
         Compile
         Simulate
         Reset Simulator
         Generate Code
         Find Usages
         Find Unused Blocks
         Settings...
      The Tools Menu
         Options...
      The Help Menu
         Help
         About RTflow...
      Main Window Toolbar Buttons
      The Project Tree
      Main Window Keyboard Shortcuts
   The Schematic Editor
      Schematic Editor - General
      Editing Operations
         Adding a Block
         Adding a Connection
         Resizing a Block
         Moving a Connection
         Renaming an Element
         Selecting Elements
         Moving a Block
         Cutting, Copying, Pasting and Deleting Elements
      Schematic Editor Toolbar Buttons
         Select Tool
         Zoom Tool
         Scroll Tool
         Show Connection Names
         Show Values
         Show Port Names
         Show Frame
         Show Grid (Schematic Editor)
         Snap to Grid
         Zoom Out (Schematic Editor)
         Zoom Level
         Zoom In (Schematic Editor)
         Pop Context (Schematic Editor)
      Schematic Editor Keyboard Shortcuts
      Properties
         Schematic Properties
         Block Instance Properties
         Connection Properties
         Port Properties
      The Blocks Tree
         Add to Schematic
         Edit Source
   Blocks
      Ports
         BoolInput
         BoolOutput
         IntInput
         IntOutput
         RealInput
         RealOutput
      Primitive
         Bool
         Int
         Real
         If
         Not
         And
         Or
         Xor
         LeftShift
         RightShift
         Add
         Sub
         Mult
         Div
         Mod
         Sqrt
         Less
         LessEqual
         Equal
         NotEqual
         Greater
         GreaterEqual
         Gain
         Identity
         Value
         Pre
         Dt
         Sin
         Cos
         Tan
         Arctan
         Arctan2
         Ln
         Exp
         Pow
      Standard
         Abs
         Distance
         Length
         Max
         Min
         Negation
         SafeArctan2
         SafeDiv
         Saturation
         Sqr
         Average
         Count
         D
         Derivative
         Integral
         IntegralWithReset
         Pid
         PositiveEdge
         SetReset
         T
         Clock
         Ramp
         Degrees2Radians
         NormalizeAngle
   The Simulator
      Simulator - General
      Simulation Settings
      Starting and Running the Simulator
      The Signal Area
         The Signal column
         The Type Column
         The Value Column
         The Force Column
         The Display Column
      The Graph Area
         Split View
         Joint View
      Simulator Toolbar Buttons
         Pop Context Toolbar Button (Simulator)
         Current Instance
         Show Subnodes Toolbar Button
         Show Inputs Toolbar Button
         Show Locals Toolbar Button
         Show Outputs Toolbar Button
         Show Grid Toolbar Button (Simulator)
         Split View Toolbar Button
         Joint View Toolbar Button
         Auto Scroll Toolbar Button
         Zoom Out Toolbar Button (Simulator)
         Zoom In Toolbar Button (Simulator)
         Restore Zoom Toolbar Button
      Simulator Keyboard Shortcuts
         Cursor Back
         Cursor Forward
   The Code Generator
      Code Generator - General
      Code Generation Settings
         C/C++/Java Generator Settings
         VHDL Generator Settings
      Key Reference
         %type_VECTOR%
         %IF_HAS_type%
         %type_NAMES%
         %type_INPUT_NAMES%
         %type_OUTPUT_NAMES%
         %NUMBER_type%
         %NUMBER_type_INPUT%
         %NUMBER_type_OUTPUT%
         %NUMBER_type_LOCAL%
         %NUMBER_type_STATE%
         %OFFSET_type_INPUT%
         %OFFSET_type_OUTPUT%
         %OFFSET_type_LOCAL%
         %OFFSET_type_STATE%
         %INITIAL_EQUATIONS%
         %OUTPUT_UPDATE_EQUATIONS%
         %STATE_UPDATE_EQUATIONS%
         %SAMPLE_TIME%
         %FREQUENCY_MHZ%
         %INPUT_MAP%
         %OUTPUT_MAP%
   Compiler Errors
      2001: Causality loop involving the following signals: signals
      2002: Output port has no source in node node.
      2006: Recursion in node node.
      2007: Equation equation not resolved in node node.
      3004: Unbound input port in equation equation of node node.
      3017: Type mismatch for signal signal (type1 / type2) in node node.
      4001/4101: Could not open template file filename.
      4002/4102: Could not open filename for writing.
      4004/4104: Error writing filename.
      4010/4110: Unknown key key.